WordPress的官方网站在内地有时候是无法正常访问的,就会导致无法更新WordPress,以及无法更新部分插件。

如果是运行一个程序,设置环境变量 http_proxy 就可以完成代理的设置;但 WordPress 是运行在 apache 下的;apache 是个服务,给启动命令设置环境变量并不能影响 apache 服务主程序,导致无法设置代理。

WordPress 可以在 wp-admin/wp-config.php 中进行设置,可以添加以下代码:

define('WP_PROXY_HOST', 'proxy.example.com');
define('WP_PROXY_PORT', '8080');
define('WP_PROXY_BYPASS_HOSTS','localhost');

  1. WORDPRESS – AUTO-UPDATE VIA PROXY

发表评论

邮箱地址不会被公开。 必填项已用*标注